e107help.org Q&A
0 like 0 dislike

After what appeared to be a succesful installation on my 1and1 website  space I can only get this page

Fatal error: Uncaught ArgumentCountError: Too few arguments to function error_handler::handle_error(), 4 passed and exactly 5 expected in /homepages/24/d862704388/htdocs/class2.php:2558 Stack trace: #0 /homepages/24/d862704388/htdocs/e107_handlers/core_functions.php(135): error_handler->handle_error(8192, 'Required parame...', '/homepages/24/d...', 3034) #1 /homepages/24/d862704388/htdocs/e107_handlers/core_functions.php(135): require_once() #2 /homepages/24/d862704388/htdocs/class2.php(266): e107_require_once('/homepages/24/d...') #3 /homepages/24/d862704388/htdocs/e107_admin/admin.php(11): require_once('/homepages/24/d...') #4 {main} thrown in /homepages/24/d862704388/htdocs/class2.php on line 2558

 

www.platnumgold.com

e107 version newest
closed with the note: Closed as solution was found
in Installation by (2 points) 2
closed by
Please take a look at this post:
https://github.com/e107inc/e107/issues/4420
Maybe you find similarities.
Ionos : advice if hosting has possibility switch  : (this time) use php 7.3  (7.4 and 8 > future)

Please post back if this might be a solution.
thank you I just got home from work, I am looking into it now. I appreciate your advice.

"Please post back if this might be a solution."

Yes that worked :) I switched php to ver. 7.3 and vuala working site, so now to start adding content. Thank you sooo much, I appreciate your help, and quick response to my issue. :)

Thank you for your reply, appreciated.
To clarify for anyone reading along: e107 2.3.0 is not compatible with PHP 8. As of the next release, e107 will be PHP 8 compatible.The current version on Github is mostly PHP8 compatible but some issues may still occur. Please report those on Github so they can be fixed.
Welcome to e107 Q&A, where you can ask questions and receive answers from other members of the e107 community.
988 questions
1,384 answers
2,511 comments
2,511 users