e107help.org Q&A
0 like 0 dislike

Hi,
I got the task to maintain a e107 based website. My experience with e107 is very limited, but up to now some smaller maintenance tasks, like changing some text worked so far.
But I now I receive an error message from TinyMCE when I want to change a page's content and the only option that is left is to change directly in the html code.

I have 2 questions related to the error message:
 

  • Is TinyMCE an integrated part of e107 or is it an option?
    I only found an older version of TinyMCE (version 3) in the plugin catalogue.
    And if TinyMCE is optional: what are other options to create content in e107?
  • And - obviously - how can I get rid of the error message and bring TinyMCE to work again?

Thank you very much for your support.

BR Christian

e107 version 2.0
in Plugins by (7 points) 1

Hi, lets try to answer somewhat..(first time this happens).
Your version might be an influence here. Is the system version true v 2.0 or higher?
Latest version in development will be 2.3.1 (2.3.0 stable).
In version 2.3.1 recently newer changes were made (and more since v 2.0), and heard no issues yet (but that could be depending on what Tiny Mce itself does with the closing of cdn paths; at present, i personally have no issues using tiny (yet)).
That in mind..
Tiny is delivered as a plugin suited to be used in e107.
You can switch it off iff not needed (admin/prefs/text/cq content filters (depending version)... find wysiwyg mode > off), so a basic editor remains.
You could try to update the sytem if version is v 2.0 to v 2.3.0 OR even the dev version (that one already has changes made for php 8 use).
Of course any update would best be accompanied by backups (files/dbase).
You also could use only overwrite the plugin itself, but newer over old may cause issues..
Here are some links for system : main : https://e107.org/download  (up to 2.3.0 version).
The dev version (2.3.x) https://github.com/e107inc/e107/.
Notice you can find tiny in the plugin folder as a sub).
Warning upgrading would also involve (when in use) language version packs  (https://github.com/e107translations).
Iff you like more info or would like to post more yourself please do.
Anyway... to be sure i create an issue report on the dev. Github)

Please see comment by dev ; https://github.com/e107inc/e107/issues/4502

So it is the version build by date. Newer versions should not have this issue.

1 Answer

0 like 0 dislike
OK, thank you very much for taking care!
Then I guess I have to make my self familar with the update process  ...
Being used to WordPress it looks a bit - let's say "basic".

Anyhow, thanks for your help!
by (7 points) 1
Welcome to e107 Q&A, where you can ask questions and receive answers from other members of the e107 community.
969 questions
1,368 answers
2,470 comments
2,485 users